Skip to content

Simulating OSPF with STUB AREA,NSSA, Restricting LSAs

Simulating OSPF with STUB AREA,NSSA, Restricting LSA’s
Stub area
A stub area is an area which does not receive route advertisements external to the autonomous system (AS) and routing from within the area is based entirely on a default route. An ABR deletes type 4, 5 LSAs from internal routers, sends them a default route of 0.0.0.0 and turns itself into a default gateway. This reduces LSDB and routing table size for internal routers.Modifications to the basic concept of stub areas exist in the not-so-stubby area (NSSA). In addition, several other proprietary variations have been implemented by systems vendors, such as the totally stubby area (TSA) and the NSSA not so stubby area, both an extension in Cisco Systems routing equipment.

Not-so-stubby area

A not-so-stubby area (NSSA) is a type of stub area that can import autonomous system external routes and send them to other areas, but still cannot receive AS-external routes from other areas. NSSA is an extension of the stub area feature that allows the injection of external routes in a limited fashion into the stub area. A case study simulates an NSSA getting around the Stub Area problem of not being able to import external addresses. It visualizes the following activities: the ASBR imports external addresses with a type 7 LSA, the ABR converts a type 7 LSA to type 5 and floods it to other areas, the ABR acts as an “ASBR” for other areas. The ABRs do not take type 5 LSAs and then convert to type 7 LSAs for the area.Here is the whole idea to do it.

Totally stubby area

A totally stubby area is similar to a stub area. However, this area does not allow summary routes in addition to not having external routes, that is, inter-area (IA) routes are not summarized into totally stubby areas. The only way for traffic to get routed outside of the area is a default route which is the only Type-3 LSA advertised into the area. When there is only one route out of the area, fewer routing decisions have to be made by the route processor, which lowers system resource utilization.Occasionally, it is said that a TSA can have only one ABR.[7]

NSSA totally stubby area

An addition to the standard functionality of an NSSA, the totally stubby NSSA is an NSSA that takes on the attributes of a TSA, meaning that type 3 and 4 summary routes are not flooded into this type of area. It is also possible to declare an area both totally stubby and not-so-stubby, which means that the area will receive only the default route from area 0.0.0.0, but can also contain an autonomous system boundary router (ASBR) that accepts external routing information and injects it into the local area, and from the local area into area 0.0.0.0.Redistribution into an NSSA area creates a special type of LSA known as type 7, which can exist only in an NSSA area. An NSSA ASBR generates this LSA, and an NSSA ABR router translates it into type 5 LSA which gets propagated into the OSPF domain.
A newly acquired subsidiary is one example of where it might be suitable for an area to be simultaneously not-so-stubby and totally stubby if the practical place to put an ASBR is on the edge of a totally stubby area. In such a case, the ASBR does send externals into the totally stubby area, and they are available to OSPF speakers within that area. In Cisco’s implementation, the external routes can be summarized before injecting them into the totally stubby area. In general, the ASBR should not advertise default into the TSA-NSSA, although this can work with extremely careful design and operation, for the limited special cases in which such an advertisement makes sense.By declaring the totally stubby area as NSSA, no external routes from the backbone, except the default route, enter the area being discussed. The externals do reach area 0.0.0.0 via the TSA-NSSA, but no routes other than the default route enter the TSA-NSSA. Routers in the TSA-NSSA send all traffic to the ABR, except to routes advertised by the ASBR

Topology

Configration

R1 OSPF

R1#conf t
R1(config)#int loopback 1
R1(config-if)#ip address 10.1.2.1 255.255.255.0
R1(config-if)#ip ospf 1 area 1
R1(config-if)#no shut
R1(config-if)#keepalive 30
R1(config-if)#exit

R1(config)#int loopback 2
R1(config-if)#ip address 10.1.3.1 255.255.255.0
R1(config-if)#ip ospf 1 area 1
R1(config-if)#no shut
R1(config-if)#keepalive 30
R1(config-if)#exit

R1(config)#int loopback 3
R1(config-if)#ip address 10.1.4.1 255.255.255.0
R1(config-if)#ip ospf 1 area 1
R1(config-if)#no shut
R1(config-if)#keepalive 30
R1(config-if)#exit

R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit

R1(config)#interface fastEthernet 0/0
R1(config-if)#ip ospf 1 area 1
R1(config-if)#exit

R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#exit
R1(config)#exit

R1#wr
R1#sh route

[after all routers configured do further chk]

R1#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     99.0.0.0/21 is subnetted, 1 subnets
O E2    99.9.0.0 [110/5] via 10.1.1.2, 00:22:54, FastEthernet0/0
     20.0.0.0/24 is subnetted, 1 subnets
O IA    20.1.1.0 [110/20] via 10.1.1.2, 00:36:10, FastEthernet0/0
     40.0.0.0/24 is subnetted, 1 subnets
O IA    40.1.1.0 [110/40] via 10.1.1.2, 00:22:59, FastEthernet0/0
     10.0.0.0/24 is subnetted, 4 subnets
C       10.1.3.0 is directly connected, Loopback2
C       10.1.2.0 is directly connected, Loopback1
C       10.1.1.0 is directly connected, FastEthernet0/0
C       10.1.4.0 is directly connected, Loopback3
     30.0.0.0/24 is subnetted, 1 subnets
O IA    30.1.1.0 [110/30] via 10.1.1.2, 00:22:56, FastEthernet0/0

[Creating STUB]

R1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#router ospf 1
R1(config-router)#area 1 stub
R1(config-router)#area 1 range 10.1.0.0 255.255.248.0
R1(config-router)#^Z
R1#wr
Building configuration…

R1#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 4 subnets
C       10.1.3.0 is directly connected, Loopback2
C       10.1.2.0 is directly connected, Loopback1
C       10.1.1.0 is directly connected, FastEthernet0/0
C       10.1.4.0 is directly connected, Loopback3

R2 OSPF

R2#conf t

R2(config)#int fastEthernet 0/0
R2(config-if)#ip address 10.1.1.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#ip ospf 1 area 1
R2(config-if)#exit

R2(config)#int fastEthernet 0/1
R2(config-if)#ip address 20.1.1.1 255.255.255.0
R2(config-if)#ip ospf 1 area 0
R2(config-if)#no shut
R2(config-if)#exit

R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2#wr
Building configuration…

R2#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     99.0.0.0/21 is subnetted, 1 subnets
O E2    99.9.0.0 [110/5] via 20.1.1.2, 00:23:11, FastEthernet0/1
     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet0/1
     40.0.0.0/24 is subnetted, 1 subnets
O IA    40.1.1.0 [110/30] via 20.1.1.2, 00:23:11, FastEthernet0/1
     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
O       10.1.2.1/32 [110/11] via 10.1.1.1, 00:41:30, FastEthernet0/0
O       10.1.3.1/32 [110/11] via 10.1.1.1, 00:41:30, FastEthernet0/0
C       10.1.1.0/24 is directly connected, FastEthernet0/0
O       10.1.4.1/32 [110/11] via 10.1.1.1, 00:41:33, FastEthernet0/0
     30.0.0.0/24 is subnetted, 1 subnets
O       30.1.1.0 [110/20] via 20.1.1.2, 00:23:13, FastEthernet0/1

[from here to form stub]

R2(config)#router ospf 1
R2(config-router)#area 1 stub
R2(config-router)#area 1 range 10.1.0.0 255.255.248.0
R2(config-router)#^Z
R2#wr
Building configuration…
[OK]

R2#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     99.0.0.0/21 is subnetted, 1 subnets
O E2    99.9.0.0 [110/5] via 20.1.1.2, 00:15:00, FastEthernet0/1
     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet0/1
     40.0.0.0/24 is subnetted, 1 subnets
O IA    40.1.1.0 [110/30] via 20.1.1.2, 00:15:00, FastEthernet0/1
     10.0.0.0/8 is variably subnetted, 5 subnets, 3 masks
O       10.1.2.1/32 [110/11] via 10.1.1.1, 00:15:00, FastEthernet0/0
O       10.1.3.1/32 [110/11] via 10.1.1.1, 00:15:00, FastEthernet0/0
C       10.1.1.0/24 is directly connected, FastEthernet0/0
O       10.1.0.0/21 is a summary, 00:15:02, Null0
O       10.1.4.1/32 [110/11] via 10.1.1.1, 00:15:02, FastEthernet0/0
     30.0.0.0/24 is subnetted, 1 subnets
O       30.1.1.0 [110/20] via 20.1.1.2, 00:15:19, FastEthernet0/1
R2#

R3 OSPF

R3#conf t
R3(config)#int loopback 1
R3(config-if)#ip address 99.9.1.1 255.255.255.0
R3(config-if)#no shut
R3(config-if)#keepalive 30
R3(config-if)#exit

R3(config)#int loopback 2
R3(config-if)#ip address 99.9.2.1 255.255.255.0
R3(config-if)#no shut
R3(config-if)#keepalive 30
R3(config-if)#exit

R3(config)#int loopback 3
R3(config-if)#ip address 99.9.3.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#keepalive 30
R3(config-if)#exit

R3(config)#int loopback 4
R3(config-if)#ip address 99.9.4.1 255.255.255.0
R3(config-if)#no shut
R3(config-if)#keepalive 30
R3(config-if)#exit

R3(config)#interface loopback 5
R3(config-if)#ip address 99.9.5.1 255.255.255.0
R3(config-if)#keepalive 30
R3(config-if)#exit

R3(config)#int fastEthernet 0/0
R3(config-if)#ip address 20.1.1.2 255.255.255.0
R3(config-if)#no shut
R3(config-if)#ip ospf 1 area 0
R3(config-if)#exit

R3(config)#int fastEthernet 0/1
R3(config-if)#ip address 30.1.1.1 255.255.255.0
R3(config-if)#no shut
R3(config-if)#ip ospf 1 area 0
R3(config-if)#exit

R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 99.0.0.0
R3(config-router)#exit

R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#summary-address 99.9.0.0 255.255.248.0
R3(config-router)#redistribute rip subnets metric 5
R3(config-router)#exit
R3#wr
Building configuration…
[OK]

R3#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     99.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C       99.9.2.0/24 is directly connected, Loopback2
C       99.9.3.0/24 is directly connected, Loopback3
O       99.9.0.0/21 is a summary, 00:34:10, Null0
C       99.9.1.0/24 is directly connected, Loopback1
C       99.9.4.0/24 is directly connected, Loopback4
C       99.9.5.0/24 is directly connected, Loopback5
     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet0/0
     40.0.0.0/24 is subnetted, 1 subnets
O IA    40.1.1.0 [110/20] via 30.1.1.2, 00:23:25, FastEthernet0/1
     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
O IA    10.1.2.1/32 [110/21] via 20.1.1.1, 00:23:25, FastEthernet0/0

R4 OSPF

R4#conf t
R4(config)#int fastEthernet 0/0
R4(config-if)#ip address 30.1.1.2 255.255.255.0
R4(config-if)#ip ospf 1 area 0
R4(config-if)#no shut
R4(config-if)#exit

R4(config)#int fastEthernet 0/1
R4(config-if)#ip address 40.1.1.1 255.255.255.0
R4(config-if)#ip ospf 1 area 2
R4(config-if)#no shut
R4(config-if)#exit

R4(config)#router ospf 1
R4(config-router)#router-id 4.4.4.4
R4(config-router)#^Z
R4#wr
Building configuration…

R4#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     99.0.0.0/21 is subnetted, 1 subnets
O E2    99.9.0.0 [110/5] via 30.1.1.1, 00:00:05, FastEthernet0/0
     20.0.0.0/24 is subnetted, 1 subnets
O       20.1.1.0 [110/20] via 30.1.1.1, 00:00:05, FastEthernet0/0
     40.0.0.0/24 is subnetted, 1 subnets
C       40.1.1.0 is directly connected, FastEthernet0/1
     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
O IA    10.1.2.1/32 [110/31] via 30.1.1.1, 00:00:05, FastEthernet0/0
O IA    10.1.3.1/32 [110/31] via 30.1.1.1, 00:00:05, FastEthernet0/0
O IA    10.1.1.0/24 [110/30] via 30.1.1.1, 00:00:07, FastEthernet0/0
O IA    10.1.4.1/32 [110/31] via 30.1.1.1, 00:00:07, FastEthernet0/0
     30.0.0.0/24 is subnetted, 1 subnets
C       30.1.1.0 is directly connected, FastEthernet0/0
R4#ping 10.1.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 88/179/252 ms

[for NSSA not so stuby]

R4#conf t
R4(config)#router ospf 1
R4(config-router)#area 2 nssa
R4(config-router)#area 2 nssa no-summary
R4(config-router)#^Z

R4#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     99.0.0.0/21 is subnetted, 1 subnets
O E2    99.9.0.0 [110/5] via 30.1.1.1, 00:04:10, FastEthernet0/0
     20.0.0.0/24 is subnetted, 1 subnets
O       20.1.1.0 [110/20] via 30.1.1.1, 00:14:42, FastEthernet0/0
     40.0.0.0/24 is subnetted, 1 subnets
C       40.1.1.0 is directly connected, FastEthernet0/1
     10.0.0.0/21 is subnetted, 1 subnets
O IA    10.1.0.0 [110/30] via 30.1.1.1, 00:04:10, FastEthernet0/0
     30.0.0.0/24 is subnetted, 1 subnets
C       30.1.1.0 is directly connected, FastEthernet0/0
R4#

R5 OSPF

[configure R5 using below details]
R5 Configurations:

R5(config)#interface Serial1/0
R5(config-if)# ip address 40.1.1.2 255.255.255.0
R5(config-if)# ip ospf 1 area 2
R4(config)#exit
R5(config)#router ospf 1
R5(config-router)# router-id 5.5.5.5
R5(config-router)#area 2 nssa

R5#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is 40.1.1.1 to network 0.0.0.0

     40.0.0.0/24 is subnetted, 1 subnets
C       40.1.1.0 is directly connected, FastEthernet0/0
O*IA 0.0.0.0/0 [110/11] via 40.1.1.1, 00:00:23, FastEthernet0/0
R5#

Leave a Reply

Your email address will not be published. Required fields are marked *

error: Content is protected !!