Skip to content

Simulating BGP

Simulating BGP

pl.Note. Though the 1st page of configuration states iBGP this practialis for BGP also

 (Image source : ccie4all.wordpress.com)
Pl.Note : 1) Firstly power up the 4 switches and copy and paste ccie_all_vlans . 
2) Setup Initial configurations on all the devices

Please remember that firstly you must build your GNS3 lab (step 1 and 2)  and copy and paste all initial  configs  then using Simulating BGP configs again paste them in into devices console in order to have above network up and running.


ccie_all_vlans : 

vlan data
vlan 3
vlan 5
vlan 7
vlan 8
vlan 9
vlan 10
vlan 12
vlan 22
vlan 40
vlan 43
vlan 58
vlan 60
vlan 67
vlan 71
vlan 79
vlan 100
vlan 111
vlan 112
vlan 113
vlan 120
vlan 140
vlan 146
vlan 200
vlan 240
vlan 300
vlan 567
vlan 735
vlan 2200
vlan 2300
vlan 2567
apply

exi

Initial Configuration: 

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!  IEWB-RSv4 BB1 !!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
en
conf t
!
version 12.2
no service timestamps debug uptime
no service timestamps log uptime
no service password-encryption
!
hostname BB1
!
logging queue-limit 100
enable secret cisco
enable password cisco
!
username ROUTER6 password 0 CISCO
clock timezone PST -8
clock summer-time PDT recurring
ip subnet-zero
no ip domain lookup
!
ipv6 unicast-routing
frame-relay switching
!
key chain EIGRP
 key 1
  key-string CISCO
!
bridge irb
!
!
interface Loopback112
 ip address 112.0.0.1 255.0.0.0
 ipv6 address 2001:254:0:112::1/64
 ipv6 rip RIPng enable
!
interface Loopback113
 ip address 113.0.0.1 255.0.0.0
 ipv6 address 2001:254:0:113::1/64
 ipv6 rip RIPng enable
!
interface Loopback114
 ip address 114.0.0.1 255.0.0.0
 ipv6 address 2001:254:0:114::1/64
 ipv6 rip RIPng enable
!
interface Loopback115
 ip address 115.0.0.1 255.0.0.0
 ipv6 address 2001:254:0:115::1/96
 ipv6 rip RIPng enable
!
interface Loopback116
 ip address 116.0.0.1 255.0.0.0
!
interface Loopback117
 ip address 117.0.0.1 255.0.0.0
!
interface Loopback118
 ip address 118.0.0.1 255.0.0.0
!
interface Loopback119
 ip address 119.0.0.1 255.0.0.0
!
interface Loopback51001
 ip address 51.0.0.1 255.255.0.0
!
interface Loopback51101
 ip address 51.1.0.1 255.255.0.0
!
interface Loopback51201
 ip address 51.2.0.1 255.255.0.0
!
interface Loopback51301
 ip address 51.3.0.1 255.255.0.0
!
interface Loopback51401
 ip address 51.4.0.1 255.255.0.0
!
interface Loopback51501
 ip address 51.5.0.1 255.255.0.0
!
interface Loopback51601
 ip address 51.6.0.1 255.255.0.0
!
interface Loopback51701
 ip address 51.7.0.1 255.255.0.0
!
interface Loopback200000
 ip address 200.0.0.1 255.255.255.0
!
interface Loopback200010
 ip address 200.0.1.1 255.255.255.0
!
interface Loopback200020
 ip address 200.0.2.1 255.255.255.0
!
interface Loopback200030
 ip address 200.0.3.1 255.255.255.0
!
interface Loopback2121801
 ip address 212.18.0.1 255.255.255.0
!
interface Loopback2121811
 ip address 212.18.1.1 255.255.255.0
!
interface Loopback2121821
 ip address 212.18.2.1 255.255.255.0
!
interface Loopback2121831
 ip address 212.18.3.1 255.255.255.0
!
interface fa 1/0
 description Connected to BB3
 ip address 172.16.4.1 255.255.255.0
 no shutdown
!
interface Virtual-Template1
 ip address 54.1.7.254 255.255.255.0
 ppp authentication chap
!
interface Virtual-Template11
 ip address 54.1.8.254 255.255.255.0
 ppp authentication pap
 ppp pap sent-username BB1 password 0 CISCO
!
interface Serial0/0
 encapsulation frame-relay
 no shut
!
interface Serial0/0.51 point-to-point
 description PVC 51 to Rack8
 ip address 54.1.3.254 255.255.255.0
 frame-relay interface-dlci 51  
!
interface Serial0/0.100 point-to-point
 description PVC 100 to Rack8
 ip address 54.1.2.254 255.255.255.0
 ipv6 address 2001:54:1:2::254/64
 ipv6 address FE80::254 link-local
 frame-relay interface-dlci 100  
!
interface Serial0/0.101 point-to-point
 description PVC 101 to Rack8
 ip address 54.1.1.254 255.255.255.0
 ip authentication mode eigrp 10 md5
 ip authentication key-chain eigrp 10 EIGRP
 ipv6 address 2001:54:254:1::254/64
 ipv6 address FE80::254 link-local
 ipv6 rip RIPng enable
 frame-relay interface-dlci 101  
!
interface Serial0/0.201 point-to-point
 description PPP over PVC 201 to Rack1
 frame-relay interface-dlci 201 ppp Virtual-Template1
!
interface Serial0/0.301 point-to-point
 description PPP over PVC 301 to Rack1
 frame-relay interface-dlci 301 ppp Virtual-Template11
!
interface Serial0/0.401 point-to-point
 description Bridging over PVC 401 to Rack1
 frame-relay interface-dlci 401  
 bridge-group 1
!
interface BVI1
 ip address 54.1.10.254 255.255.255.0
!
router eigrp 10
 network 54.0.0.0
 network 200.0.0.0 0.0.3.255
 distribute-list EIGRP out
 distribute-list prefix DENY_DEFAULT in
 no auto-summary
 no eigrp log-neighbor-changes
 no eigrp log-neighbor-warnings
!
router rip
 version 2
 network 54.0.0.0
 network 150.8.0.0
 network 155.8.0.0
 network 192.10.6.0
 network 204.12.5.0
 network 212.18.0.0
 network 212.18.1.0
 network 212.18.2.0
 network 212.18.3.0
 distribute-list RIP out
 no auto-summary
!
router bgp 54
 no synchronization
 bgp log-neighbor-changes
 neighbor RACKS peer-group
 neighbor RACKS remote-as 100
 neighbor 2001:54:1:2::6 remote-as 100
 neighbor 2001:54:1:4::6 remote-as 100
 neighbor 2001:54:254:1::6 remote-as 100
 neighbor 2001:172:16:4::3 remote-as 54
 neighbor 54.1.1.6 peer-group RACKS
 neighbor 54.1.2.6 peer-group RACKS
 neighbor 54.1.3.6 peer-group RACKS
 neighbor 54.1.4.6 peer-group RACKS
 neighbor 54.1.5.6 peer-group RACKS
 neighbor 54.1.6.6 peer-group RACKS
 neighbor 54.1.7.6 peer-group RACKS
 neighbor 54.1.8.6 peer-group RACKS
 neighbor 54.1.10.100 peer-group RACKS
 neighbor 172.16.4.3 remote-as 54
 no auto-summary
 !
 address-family ipv4 multicast
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv6
 neighbor 2001:54:1:2::6 activate
 neighbor 2001:54:1:4::6 activate
 neighbor 2001:54:254:1::6 activate
 neighbor 2001:172:16:4::3 activate
 network 2001:254:0:112::1/64
 network 2001:254:0:113::1/64
 network 2001:254:0:114::1/64
 network 2001:254:0:115::1/96
 exit-address-family
 !
 address-family ipv4
 neighbor RACKS activate
 neighbor RACKS send-community
 neighbor RACKS route-map BGP_IN in
 neighbor RACKS route-map BGP_OUT out
 no neighbor 2001:54:1:2::6 activate
 no neighbor 2001:54:1:4::6 activate
 no neighbor 2001:54:254:1::6 activate
 no neighbor 2001:172:16:4::3 activate
 neighbor 54.1.1.6 peer-group RACKS
 neighbor 54.1.2.6 peer-group RACKS
 neighbor 54.1.3.6 peer-group RACKS
 neighbor 54.1.4.6 peer-group RACKS
 neighbor 54.1.5.6 peer-group RACKS
 neighbor 54.1.6.6 peer-group RACKS
 neighbor 54.1.7.6 peer-group RACKS
 neighbor 54.1.8.6 peer-group RACKS
 neighbor 54.1.10.100 peer-group RACKS
 neighbor 172.16.4.3 activate
 neighbor 172.16.4.3 next-hop-self
 neighbor 172.16.4.3 send-community
 no auto-summary
 no synchronization
 network 112.0.0.0
 network 113.0.0.0
 network 114.0.0.0 route-map SET_COMMUNITY_54
 network 115.0.0.0 route-map SET_COMMUNITY_54
 network 116.0.0.0
 network 117.0.0.0
 network 118.0.0.0
 network 119.0.0.0
 exit-address-family
!
ip http server
ip classless
!
ip as-path access-list 1 permit ^$
!
!
ip prefix-list BGP_PREPEND_1 seq 5 permit 112.0.0.0/8
ip prefix-list BGP_PREPEND_1 seq 10 permit 113.0.0.0/8
!
ip prefix-list DEFAULT seq 5 permit 0.0.0.0/0
!
ip prefix-list DENY_DEFAULT seq 5 deny 0.0.0.0/0
ip prefix-list DENY_DEFAULT seq 10 permit 0.0.0.0/0 le 32
!
ip access-list standard EIGRP
 permit 200.0.0.0 0.0.3.255
ip access-list standard RIP
 permit 212.18.0.0 0.0.3.0
!
ipv6 route 2001:204::/32 2001:172:16:4::3
ipv6 router rip RIPng
  distribute-list prefix-list RIPng out 
!
!
!
ipv6 prefix-list RIPng seq 5 permit 2001:254:0:112::/64
ipv6 prefix-list RIPng seq 10 permit 2001:254:0:113::/64
ipv6 prefix-list RIPng seq 15 permit 2001:254:0:114::/64
ipv6 prefix-list RIPng seq 20 permit 2001:254:0:115::/96
route-map BGP_IN deny 10
 match ip address prefix-list DEFAULT
!
route-map BGP_IN permit 10000
!
route-map SET_COMMUNITY_54 permit 10
 set community 54
!
route-map BGP_OUT permit 10
 match ip address prefix-list BGP_PREPEND_1
 set as-path prepend 50 60
!
route-map BGP_OUT permit 10000
 match as-path 1
!
bridge 1 protocol ieee
bridge 1 route ip
privilege exec level 0 telnet
privilege exec level 0 traceroute
privilege exec level 0 ping
privilege exec level 1 terminal length
privilege exec level 1 terminal
privilege exec level 0 show ip bgp neighbors
privilege exec level 0 show ip bgp summary
privilege exec level 0 show ip bgp
privilege exec level 0 show ip route
privilege exec level 0 show ip protocols
privilege exec level 0 show ip
privilege exec level 0 show
!
line con 0
 exec-timeout 0 0
line aux 0
 transport input all
line vty 0 4
 exec-timeout 0 15
 privilege level 0
 no login
!
ntp authentication-key 1 md5 CISCO
ntp trusted-key 1
ntp master 4

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!  IEWB-RSv4 BB2 !!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
en
conf t
!
version 12.2
no service timestamps debug uptime
no service timestamps log uptime
no service password-encryption
!
hostname BB2
!
logging queue-limit 100
enable secret cisco
!
clock timezone PST -8
clock summer-time PDT recurring
ip subnet-zero
no ip domain lookup
!
ipv6 unicast-routing
frame-relay switching
!
key chain RIP
 key 1
  key-string CISCO
!
!
!
interface Loopback0
 ip address 220.20.3.1 255.255.255.0
 ipv6 address 2001:220:20:3::1/64
 ipv6 rip RIPng enable
!
interface Loopback1
 ip address 222.22.2.1 255.255.255.0
 ipv6 address 2001:222:22:2::1/64
 ipv6 rip RIPng enable
!
interface Loopback3
 ip address 205.90.31.1 255.255.255.0
 ipv6 address 2001:205:90:31::1/64
 ipv6 rip RIPng enable
!
interface Loopback100
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback51515151
 ip address 51.51.51.51 255.255.255.255
 ipv6 address 2001:51:51:51::51/64
!
interface fa 0/0
 description FatEthernet to SW3 Fa1/2
 ip address 192.10.1.254 255.255.255.0
 ip rip authentication mode md5
 ip rip authentication key-chain RIP
 ipv6 address 2001:192:10:1::254/64
 ipv6 rip RIPng enable
 ipv6 ospf 1 area 0
 no shut
 spee 100
 dup ful
!
router ospf 1
 router-id 192.10.1.254
 log-adjacency-changes
 redistribute connected subnets route-map LO51515151
 network 192.10.1.254 0.0.0.0 area 51
!
router rip
 version 2
 redistribute connected metric 7 route-map LOOPBACKS
 network 192.10.1.0
 distribute-list prefix LOOPBACKS out
!
router bgp 254
 no synchronization
 bgp log-neighbor-changes
 neighbor RACKS peer-group
 neighbor RACKS remote-as 200
 neighbor RACKS password CISCO
 neighbor 2001:192:10:1::100 remote-as 200
 neighbor 192.10.1.1 peer-group RACKS
 neighbor 192.10.1.2 peer-group RACKS
 neighbor 192.10.1.3 peer-group RACKS
 neighbor 192.10.1.4 peer-group RACKS
 neighbor 192.10.1.5 peer-group RACKS
 neighbor 192.10.1.6 peer-group RACKS
 neighbor 192.10.1.7 peer-group RACKS
 neighbor 192.10.1.8 peer-group RACKS
 neighbor 192.10.1.9 peer-group RACKS
 neighbor 192.10.1.10 peer-group RACKS
 no auto-summary
 !
 address-family ipv4 multicast
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv6
 neighbor 2001:192:10:1::100 activate
 network 2001:205:90:31::/64
 network 2001:220:20:3::/64
 network 2001:222:22:2::/64
 exit-address-family
 !
 address-family ipv4
 redistribute connected route-map LOOPBACKS
 neighbor RACKS activate
 neighbor RACKS route-map BGP_IN in
 neighbor RACKS route-map BGP_OUT out
 no neighbor 2001:192:10:1::100 activate
 neighbor 192.10.1.1 peer-group RACKS
 neighbor 192.10.1.2 peer-group RACKS
 neighbor 192.10.1.3 peer-group RACKS
 neighbor 192.10.1.4 peer-group RACKS
 neighbor 192.10.1.5 peer-group RACKS
 neighbor 192.10.1.6 peer-group RACKS
 neighbor 192.10.1.7 peer-group RACKS
 neighbor 192.10.1.8 peer-group RACKS
 neighbor 192.10.1.9 peer-group RACKS
 neighbor 192.10.1.10 peer-group RACKS
 no auto-summary
 no synchronization
 exit-address-family
!
ip http server
ip classless
!
ip as-path access-list 1 permit ^$
!
!
ip prefix-list DEFAULT seq 5 permit 0.0.0.0/0
!
ip prefix-list LOOPBACKS seq 5 permit 205.90.31.0/24
ip prefix-list LOOPBACKS seq 10 permit 220.20.3.0/24
ip prefix-list LOOPBACKS seq 15 permit 222.22.2.0/24
!
logging trap debugging
logging 192.10.1.42
ipv6 router ospf 1
 router-id 192.10.1.254
 log-adjacency-changes
 redistribute connected route-map OSPFv3_LOOPBACK
!
ipv6 router rip RIPng
  distribute-list prefix-list RIPng out 
!
!
!
ipv6 prefix-list OSPFv3_LOOPBACK seq 5 permit 2001:51:51:51::/64
!
ipv6 prefix-list RIPng seq 5 permit 2001:205:90:31::/64
ipv6 prefix-list RIPng seq 10 permit 2001:220:20:3::/64
ipv6 prefix-list RIPng seq 15 permit 2001:222:22:2::/64
route-map LO51515151 permit 10
 match interface Loopback51515151
!
route-map OSPFv3_LOOPBACK permit 10
 match ipv6 address prefix-list OSPFv3_LOOPBACK
!
route-map BGP_IN deny 10
 match ip address prefix-list DEFAULT
!
route-map BGP_IN permit 10000
!
route-map LOOPBACKS permit 10
 match ip address prefix-list LOOPBACKS
!
route-map BGP_OUT permit 10000
 match as-path 1
!
alias exec c conf t
alias exec s show run
alias exec r show ip route
privilege exec level 0 telnet
privilege exec level 0 traceroute
privilege exec level 0 ping
privilege exec level 1 terminal length
privilege exec level 1 terminal
privilege exec level 0 show ip bgp neighbors
privilege exec level 0 show ip bgp summary
privilege exec level 0 show ip bgp
privilege exec level 0 show ip route
privilege exec level 0 show ip protocols
privilege exec level 0 show ip
privilege exec level 0 show
!
line con 0
 exec-timeout 0 0
line aux 0
 no exec
 transport input all
line vty 0 4
 exec-timeout 0 15
 privilege level 0
 no login
!
ntp authentication-key 1 md5 CISCO
ntp master 4
end

********************************************   End of BB2 *********************************************************
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!  IEWB-RSv4 BB3 !!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
en
conf t
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname BB3
!
logging queue-limit 100
enable secret cisco
!
clock timezone PST -8
clock summer-time PDT recurring
ip subnet-zero
no ip domain lookup
!
ipv6 unicast-routing
!
key chain CISCO
 key 1
  key-string CISCO
!
!
!
interface Loopback0
 ip address 28.119.16.1 255.255.255.0
 ipv6 address 2001:28:119:16::1/64
!
interface Loopback1
 ip address 28.119.17.1 255.255.255.0
 ipv6 address 2001:28:119:17::1/64
!
interface Loopback10
 ip address 30.0.0.1 255.255.0.0
 ipv6 address 2001:30::1/64
 ipv6 rip RIPng enable
!
interface Loopback11
 ip address 30.1.0.1 255.255.0.0
 ipv6 address 2001:30:1::1/64
 ipv6 rip RIPng enable
!
interface Loopback12
 ip address 30.2.0.1 255.255.0.0
 ipv6 address 2001:30:2::1/64
 ipv6 rip RIPng enable
!
interface Loopback13
 ip address 30.3.0.1 255.255.0.0
 ipv6 address 2001:30:3::1/64
 ipv6 rip RIPng enable
!
interface Loopback14
 ip address 31.0.0.1 255.255.0.0
 ipv6 address 2001:31::1/64
 ipv6 rip RIPng enable
!
interface Loopback15
 ip address 31.1.0.1 255.255.0.0
 ipv6 address 2001:31:1::1/64
 ipv6 rip RIPng enable
!
interface Loopback16
 ip address 31.2.0.1 255.255.0.0
 ipv6 address 2001:31:2::1/64
 ipv6 rip RIPng enable
!
interface Loopback17
 ip address 31.3.0.1 255.255.0.0
 ipv6 address 2001:31:3::1/64
 ipv6 rip RIPng enable
!
interface fa 0/0
 description Ethernet to SW3 Fa1/3
 ip address 204.12.1.254 255.255.255.0
 ipv6 address 2001:204:12:1::254/64
 ipv6 rip RIPng enable
 no shut
!
interface fa 1/0
 description Connected to BB1
 ip address 172.16.4.3 255.255.255.0
 no shut
!
router rip
 version 2
 network 30.0.0.0
 network 31.0.0.0
 network 204.12.1.0
 distribute-list 1 in fa 0/0
 distribute-list prefix RIP out
 no auto-summary
!
router bgp 54
 no synchronization
 bgp log-neighbor-changes
 neighbor RACKS peer-group
 neighbor RACKS remote-as 100
 neighbor 2001:172:16:4::1 remote-as 54
 neighbor 2001:204:12:1::100 remote-as 100
 neighbor 172.16.4.1 remote-as 54
 neighbor 204.12.1.1 peer-group RACKS
 neighbor 204.12.1.2 peer-group RACKS
 neighbor 204.12.1.3 peer-group RACKS
 neighbor 204.12.1.4 peer-group RACKS
 neighbor 204.12.1.5 peer-group RACKS
 neighbor 204.12.1.6 peer-group RACKS
 neighbor 204.12.1.7 peer-group RACKS
 neighbor 204.12.1.8 peer-group RACKS
 neighbor 204.12.1.9 peer-group RACKS
 neighbor 204.12.1.10 peer-group RACKS
 no auto-summary
 !
 address-family ipv4 multicast
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv6
 neighbor 2001:172:16:4::1 activate
 neighbor 2001:204:12:1::100 activate
 network 2001:28:119:16::/64
 network 2001:28:119:17::/64
 exit-address-family
 !
 address-family ipv4
 neighbor RACKS activate
 neighbor RACKS send-community
 neighbor RACKS route-map BGP_IN in
 neighbor RACKS route-map BGP_OUT out
 no neighbor 2001:172:16:4::1 activate
 no neighbor 2001:204:12:1::100 activate
 neighbor 172.16.4.1 activate
 neighbor 172.16.4.1 next-hop-self
 neighbor 172.16.4.1 send-community
 neighbor 204.12.1.1 peer-group RACKS
 neighbor 204.12.1.2 peer-group RACKS
 neighbor 204.12.1.3 peer-group RACKS
 neighbor 204.12.1.4 peer-group RACKS
 neighbor 204.12.1.5 peer-group RACKS
 neighbor 204.12.1.6 peer-group RACKS
 neighbor 204.12.1.7 peer-group RACKS
 neighbor 204.12.1.8 peer-group RACKS
 neighbor 204.12.1.9 peer-group RACKS
 neighbor 204.12.1.10 peer-group RACKS
 no auto-summary
 no synchronization
 network 28.119.16.0 mask 255.255.255.0
 network 28.119.17.0 mask 255.255.255.0
 exit-address-family
!
no ip http server
ip classless
ip route 54.0.0.0 255.0.0.0 172.16.4.1
!
!
!
ip prefix-list BGP_PREPEND_1 seq 5 permit 112.0.0.0/8
ip prefix-list BGP_PREPEND_1 seq 10 permit 113.0.0.0/8
!
ip prefix-list DEFAULT seq 5 permit 0.0.0.0/0
!
ip prefix-list RIP seq 5 permit 30.0.0.0/14 ge 16 le 16
ip prefix-list RIP seq 10 permit 31.0.0.0/14 ge 16 le 16
!
access-list 1 deny   0.0.0.0
access-list 1 permit 150.1.0.0 0.0.255.255
access-list 1 deny   150.0.0.0 0.255.255.255
access-list 1 permit any
ipv6 route 2001:54::/32 2001:172:16:4::1
ipv6 route ::/0 Null0
ipv6 router rip RIPng
  distribute-list prefix-list RIPng out  
!
!
!
ipv6 prefix-list RIPng seq 5 permit 2001:30::/64
ipv6 prefix-list RIPng seq 10 permit 2001:30:1::/64
ipv6 prefix-list RIPng seq 15 permit 2001:30:2::/64
ipv6 prefix-list RIPng seq 20 permit 2001:30:3::/64
ipv6 prefix-list RIPng seq 25 permit 2001:31::/64
ipv6 prefix-list RIPng seq 30 permit 2001:31:1::/64
ipv6 prefix-list RIPng seq 35 permit 2001:31:2::/64
ipv6 prefix-list RIPng seq 40 permit 2001:31:3::/64
route-map BGP_IN deny 10
 match ip address prefix-list DEFAULT
!
route-map BGP_IN permit 1000
!
route-map BGP_OUT permit 10
 match ip address prefix-list BGP_PREPEND_1
 set as-path prepend 50 60
!
route-map BGP_OUT permit 10000
!
privilege exec level 0 telnet
privilege exec level 0 traceroute
privilege exec level 0 ping
privilege exec level 1 terminal length
privilege exec level 1 terminal
privilege exec level 0 show ip bgp neighbors
privilege exec level 0 show ip bgp summary
privilege exec level 0 show ip bgp
privilege exec level 0 show ip route
privilege exec level 0 show ip protocols
privilege exec level 0 show ip
privilege exec level 0 show
!
line con 0
 exec-timeout 0 0
 privilege level 0
line aux 0
line vty 0 4
 privilege level 0
 no login
!
ntp authentication-key 1 md5 CISCO
ntp master 4
end


********************************************   End of BB3 ********************************************************
host Frame_Switch
!
frame-relay switching
!
interface Serial0/1
 description Connected to Rack1R1
 encapsulation frame-relay
 clockrate 64000
 frame-relay intf-type dce
 frame-relay route 102 interface Serial0/2 201
 frame-relay route 103 interface Serial0/3 301
 frame-relay route 104 interface Serial0/4 401
 frame-relay route 105 interface Serial0/5 501
 frame-relay route 113 interface Serial1/3 311
 no shut
!
interface Serial0/2
 description Connected to Rack1R2
 encapsulation frame-relay
 clockrate 64000
 frame-relay intf-type dce
 frame-relay route 201 interface Serial0/1 102
 frame-relay route 203 interface Serial0/3 302
 frame-relay route 204 interface Serial0/4 402
 frame-relay route 205 interface Serial0/5 502
 frame-relay route 213 interface Serial1/3 312
 no shut
!
interface Serial0/3
 description Connected to Rack1R3
 encapsulation frame-relay
 clockrate 64000
 frame-relay intf-type dce
 frame-relay route 301 interface Serial0/1 103
 frame-relay route 302 interface Serial0/2 203
 frame-relay route 304 interface Serial0/4 403
 frame-relay route 305 interface Serial0/5 503
 no shut
!
interface Serial1/3
 description Connected to Rack1R3
 encapsulation frame-relay
 clockrate 64000
 frame-relay intf-type dce
 frame-relay route 311 interface Serial0/1 113
 frame-relay route 312 interface Serial0/2 213
 frame-relay route 314 interface Serial0/4 413
 frame-relay route 315 interface Serial0/5 513
 no shut
!
interface Serial0/4
 description Connected to Rack1R4
 encapsulation frame-relay
 clockrate 64000
 frame-relay intf-type dce
 frame-relay route 401 interface Serial0/1 104
 frame-relay route 402 interface Serial0/2 204
 frame-relay route 403 interface Serial0/3 304
 frame-relay route 405 interface Serial0/5 504
 frame-relay route 413 interface Serial1/3 314
 no shut
!
interface Serial0/5
 description Connected to Rack1R5
 encapsulation frame-relay
 clockrate 64000
 frame-relay intf-type dce
 frame-relay route 501 interface Serial0/1 105
 frame-relay route 502 interface Serial0/2 205
 frame-relay route 503 interface Serial0/3 305
 frame-relay route 504 interface Serial0/4 405
 frame-relay route 513 interface Serial1/3 315
 no shut
!
interface Serial0/0
 description Connected to Rack1R6
 encapsulation frame-relay
 clockrate 64000
 frame-relay intf-type dce
 frame-relay route 51 interface Serial1/1 51
 frame-relay route 100 interface Serial1/1 100
 frame-relay route 101 interface Serial1/1 101
 frame-relay route 201 interface Serial1/1 201
 frame-relay route 301 interface Serial1/1 301
 frame-relay route 401 interface Serial1/1 401
 no shut
!
interface Serial1/1
 description Connected to BB1
 encapsulation frame-relay
 clockrate 64000
 frame-relay intf-type dce
 frame-relay route 51 interface Serial0/0 51
 frame-relay route 100 interface Serial0/0 100
 frame-relay route 101 interface Serial0/0 101
 frame-relay route 201 interface Serial0/0 201
 frame-relay route 301 interface Serial0/0 301
 frame-relay route 401 interface Serial0/0 401
 no shut
!
 ********************************************   End of Frame Switch ********************************************************
 R1
!
en
conf t
!
hostname Rack1R1
!
interface Loopback0
 ip address 150.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 155.1.146.1 255.255.255.0
 speed 100
 dup full
 no shut
!
interface Serial0/0
 ip address 155.1.0.1 255.255.255.0
 encapsulation frame-relay
 clock rate 2000000
 no frame-relay inverse-arp
 no arp frame-relay
 no shut
 frame-relay map ip 155.1.0.2 105 broadcast
 frame-relay map ip 155.1.0.3 105 broadcast
 frame-relay map ip 155.1.0.4 105 broadcast
 frame-relay map ip 155.1.0.5 105 broadcast
 no frame-relay inverse-arp
!
interface FastEthernet0/1
 no ip address
 shutdown
 dup full
 !
interface Serial0/1
 ip address 155.1.13.1 255.255.255.0
 clock rate 2000000
 no shut

 ********************************************   End of R1 ********************************************************

hostname Rack1R2
!
interface Loopback0
 ip address 150.1.2.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.10.1.2 255.255.255.0
 no shutdown
 speed 100
 full-duplex
!
interface Serial0/0
 ip address 155.1.0.2 255.255.255.0
 encapsulation frame-relay
 no fair-queue
 serial restart-delay 0
 clock rate 2000000
 no arp frame-relay
 no shut
 frame-relay map ip 155.1.0.1 205 broadcast
 frame-relay map ip 155.1.0.3 205 broadcast
 frame-relay map ip 155.1.0.4 205 broadcast
 frame-relay map ip 155.1.0.5 205 broadcast
 no frame-relay inverse-arp
!
interface Serial0/1
 ip address 155.1.23.2 255.255.255.0
 clock rate 2000000
 no shut
!
  ********************************************   End of R2 ********************************************************
hostname Rack1R3
!
interface Loopback0
 ip address 150.1.3.3 255.255.255.0
!
interface FastEthernet0/0
 ip address 155.1.37.3 255.255.255.0
 speed 100
 full-duplex
 no shut
!
interface Serial1/0
 ip address 155.1.0.3 255.255.255.0
 encapsulation frame-relay
 no fair-queue
 serial restart-delay 0
 no arp frame-relay
 no shut
 frame-relay map ip 155.1.0.1 305 broadcast
 frame-relay map ip 155.1.0.2 305 broadcast
 frame-relay map ip 155.1.0.4 305 broadcast
 frame-relay map ip 155.1.0.5 305 broadcast
 no frame-relay inverse-arp
!
interface Serial1/2
 ip address 155.1.13.3 255.255.255.0
 serial restart-delay 0
 no shut
!
interface Serial1/3
 ip address 155.1.23.3 255.255.255.0
 serial restart-delay 0
 no shut
!
hostname Rack1R4
!
interface Loopback0
 ip address 150.1.4.4 255.255.255.0
!
interface FastEthernet0/0
 ip address 204.12.1.4 255.255.255.0
 no shutdown
 duplex ful
 speed 100
!
interface Serial0/0
 ip address 155.1.0.4 255.255.255.0
 encapsulation frame-relay
 no fair-queue
 clock rate 2000000
 no arp frame-relay
 no shut
 frame-relay map ip 155.1.0.1 405 broadcast
 frame-relay map ip 155.1.0.2 405 broadcast
 frame-relay map ip 155.1.0.3 405 broadcast
 frame-relay map ip 155.1.0.5 405 broadcast
 no frame-relay inverse-arp
!
interface FastEthernet0/1
 ip address 155.1.146.4 255.255.255.0
 no shut
 speed 100
 full-duplex
!
interface Serial0/1
 ip address 155.1.45.4 255.255.255.0
 clock rate 2000000
 no shut

R5
en
conf t
!
hostname Rack1R5
!
interface Loopback0
 ip address 150.1.5.5 255.255.255.0
!
interface FastEthernet0/0
 ip address 155.1.58.5 255.255.255.0
 speed 100
 full-duplex
 no shut
!
interface Serial0/0
 ip address 155.1.0.5 255.255.255.0
 encapsulation frame-relay
 clock rate 2000000
 no arp frame-relay
 no shut
 frame-relay map ip 155.1.0.1 501 broadcast
 frame-relay map ip 155.1.0.2 502 broadcast
 frame-relay map ip 155.1.0.3 503 broadcast
 frame-relay map ip 155.1.0.4 504 broadcast
 no frame-relay inverse-arp
!
interface FastEthernet0/1
 ip address 155.1.5.5 255.255.255.0
 speed 100
 full-duplex
 no shut
!
interface Serial0/1
 ip address 155.1.45.5 255.255.255.0
 clock rate 2000000
 no shut
!

hostn6ame Rack1R6
!
interface Loopback0
 ip address 150.1.6.6 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 speed 100
 full-duplex
 no shut
!
interface FastEthernet0/0.67
 encapsulation dot1Q 67
 ip address 155.1.67.6 255.255.255.0
!
interface FastEthernet0/0.146
 encapsulation dot1Q 146
 ip address 155.1.146.6 255.255.255.0
 !
interface Serial0/0
 ip address 54.1.1.6 255.255.255.0
 encapsulation frame-relay
 no shutdown
 no fair-queue
 clock rate 2000000
 frame-relay interface-dlci 101
!


hostname Rack1SW1
!
interface Loopback0
 ip address 155.0.7.7 255.255.255.0
!
interface Port-channel1
 description TO SW3
 switchport mode trunk
!
interface Port-channel2
 description TO SW 4
 switchport mode trunk
!
interface Port-channel3
 description TO SW 2
 switchport mode trunk
!
interface FastEthernet1/1
 switchport access vlan 146
 no shu
!
interface FastEthernet1/2
 switchport access vlan 22
 no shut
!
interface FastEthernet1/3
 no switchport
 ip address 155.1.37.7 255.255.255.0
 no shut
!
interface FastEthernet1/4
 switchport access vlan 43
 no shut
!
interface FastEthernet1/5
 switchport access vlan 58
 no shut
!
interface FastEthernet1/6
 switchport mode trunk
 switchport trunk allowed vlan 1,67,146,1002-1005
 no shut
!
interface FastEthernet1/7
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/8
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/9
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/10
 switchport mode trunk
 channel-group 2 mode on
!
interface FastEthernet1/11
 switchport mode trunk
 channel-group 2 mode on
!
interface FastEthernet1/12
 switchport mode trunk
 channel-group 2 mode on
!
interface FastEthernet1/13
 switchport mode trunk
 channel-group 3 mode on
!
interface FastEthernet1/14
 switchport mode trunk
 channel-group 3 mode on
!
interface FastEthernet1/15
 switchport mode trunk
 channel-group 3 mode on
!
interface Vlan1
 no ip address
!
interface Vlan7
 ip address 155.1.7.7 255.255.255.0
 no shut
!
interface Vlan67
 ip address 155.1.67.7 255.255.255.0
 no shut
!
interface Vlan79
 ip address 155.1.79.7 255.255.255.0
 no shut
!

hostname Rack1SW2
!
interface Loopback0
 ip address 155.0.8.8 255.255.255.0
!
interface Port-channel1
 description TO SW4
 switchport mode trunk
!
interface Port-channel2
 description TO SW3
 switchport mode trunk
!
interface Port-channel3
 description TO SW1
 switchport mode trunk
!
interface FastEthernet1/4
 switchport access vlan 146
 no shut
!
interface FastEthernet1/5
 switchport access vlan 5
 no shut
!
interface FastEthernet1/7
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/8
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/9
 no switchport
 ip address 155.1.108.8 255.255.255.0
 no shut
!
interface FastEthernet1/10
 switchport mode trunk
 channel-group 2 mode on
!
interface FastEthernet1/11
 switchport mode trunk
 channel-group 2 mode on
!
interface FastEthernet1/12
 switchport mode trunk
 channel-group 2 mode on
!
interface FastEthernet1/13
 switchport mode trunk
 channel-group 3 mode on
!
interface FastEthernet1/14
 switchport mode trunk
 channel-group 3 mode on
!
interface FastEthernet1/15
 switchport mode trunk
 channel-group 3 mode on
!
interface Vlan1
 no ip address
!
interface Vlan8
 ip address 155.1.8.8 255.255.255.0
 no shut
!
interface Vlan58
 ip address 155.1.58.8 255.255.255.0
 no shut
!

hostname Rack1SW3
!
interface Loopback0
 ip address 155.0.9.9 255.255.255.0
!
interface Port-channel1
 desc TO SW1
 switchport mode trunk
!
interface Port-channel2
 desc TO SW2
 switchport mode trunk
!
interface Port-channel3
 desc TO SW4
 switchport mode trunk
!
interface FastEthernet1/2
 switchport access vlan 22
 no shut
!
interface FastEthernet1/3
 switchport access vlan 43
 no shut
!
interface FastEthernet1/7
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/8
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/9
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/10
 switchport mode trunk
 channel-group 2 mode on
!
interface FastEthernet1/11
 switchport mode trunk
 channel-group 2 mode on
!
interface FastEthernet1/12
 switchport mode trunk
 channel-group 2 mode on
!
interface FastEthernet1/13
 switchport mode trunk
 channel-group 3 mode on
!
interface FastEthernet1/14
 switchport mode trunk
 channel-group 3 mode on
!
interface FastEthernet1/15
 switchport mode trunk
 channel-group 3 mode on
!
interface Vlan1
 no ip address
!
interface Vlan9
 ip address 155.1.9.9 255.255.255.0
 no shut
!
interface Vlan79
 ip address 155.1.79.9 255.255.255.0
 no shut
!

hostname Rack1SW4
!
interface Loopback0
 ip address 155.0.10.10 255.255.255.0
!
interface Port-channel1
 description TO SW3
 switchport mode trunk
!
interface Port-channel2
 description TO SW1
 switchport mode trunk
!
interface Port-channel3
 description TO SW2
 switchport mode trunk
!
interface FastEthernet1/7
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/8
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/9
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet1/10
 switchport mode trunk
 channel-group 2 mode on
!
interface FastEthernet1/11
 switchport mode trunk
 channel-group 2 mode on
!
interface FastEthernet1/12
 switchport mode trunk
 channel-group 2 mode on
!
interface FastEthernet1/13
 switchport mode trunk
 channel-group 3 mode on
!
interface FastEthernet1/14
 switchport mode trunk
 channel-group 3 mode on
!
interface FastEthernet1/15
 no switchport
 ip address 155.1.108.10 255.255.255.0
 no shut
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address 155.1.10.10 255.255.255.0
 no shut
!

************************************************ End of initial setup ***********************************
Simulating BGP


BGP Commands
router bgp
Detailed information on TCP and BGP neighbor connections
neighbour [ip address]remote as [process id]
Adds a neighbour to BGP neighbor table and identifies the neighbor as EBGP or IBGP
Show ip route summary
Summary of all routes
Show ip bgp
Bgp information

Leave a Reply

Your email address will not be published. Required fields are marked *

error: Content is protected !!